Exercise 4, Chapter 4 – Custom Kali Linux ARM Install

This topic contains 6 replies, has 3 voices, and was last updated by  James Hadley 1 week, 6 days ago.

  • Author
    Posts
  • #17069

    Florin
    Participant

    Hi guys, I need a little help, please.Where am I wrong?

    My Kali Linux is run in a Virtualbox machine with 4GB RAM, 4 processors and 30 GB of HDD. I’m trying the exercise 4 of the Kali installation chapter but I can’t build the custom image for my Raspberry Pi3. Everything OK until the launch of the script ./rpi3-nexmon.sh 1.0 that never goes well, I always get the following error:
    “…–2019-01-27 11: 45: 31– https://re4son-kernel.com/keys/http/archive-key.asc
    Resolving re4son-kernel.com (re4son-kernel.com) … 67.209.124.76
    Connecting to re4son-kernel.com (re4son-kernel.com) | 67.209.124.76 |: 443 … connected.
    HTTP request sent, awaiting response … 200 OK
    Length: 1786 (1.7K) [application / pgp-signature]
    Saving to: ‘STDOUT’
    – 100% [============================================== ============>] 1.74K –.- KB / s in 0.001s
    2019-01-27 11:45:32 (1.82 MB / s) – written to stdout [1786/1786]

    E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation
    Container mZEAyI7FbFqZhnAZ failed with error code 255.”

    I’ve search on various forums, I’ve try to install gnupg (apt-get install gnupg) but nothing to do. I’d like to prepare the Raspberry as Acces Point.
    Can anybody help me please? I’m stuck … I don’t know what to do anymore, a little clue would be very appreciated.
    Thank you in advance.

  • #17083

    Mike
    Participant

    I know this might be a couple of months late, but in the interest of helping anyone else who might run into this:

    I ran into the exact same issue today. The main difference between my issue and the OP is that my Kali VM was running in Hyper-V and only had 2 GB of Ram and 2 processors.

    First I tried installing gnupg, gnupg1 and gnupg2 on my base system. The first was installed, the other two were not. Ran the script again, but no joy. Then I thought maybe the script was calling for a package inside the build itself. So under the arm/base/tools/services section, I added extras=”gnupg” and reran the script. It completed!

    During the process, I saw a bunch of warnings. “gpg: Warning: using insecure memory!” After a quick google I found an article on TechRepublic explaining that this occurs when the RAM becomes full while gpg is running, forcing it to use swap space, which is less secure by default.

    Two caveats: First, even though the script appears to have completed successfully, I don’t have the three files that the Exercise says I should have. in the rpi2-nexmon-1.0 directory that is created during the process, I have a kali-armhf directory, a root directory, and a kali-linux-1.0-rpi3-nexmon.img. I suspect that the img is what I really need, as that will get flashed to the sd card. Second, this just completed and I haven’t yet flashed it to an sd card to try in my RPi3. So I can’t yet confirm that it works as desired, however this does address getting beyond the error message seen in the original post. I’ll try to follow up once I can get it installed and tested.

  • #17084

    James Hadley
    Participant

    I’ve run into exactly this same issue and was pondering adding in the gnupg to the build – have you managed to flash and run this yet?

    (Glad I found this forum – I posted in the main forum and got a rather sharp “warning” for my troubles……. )

  • #17086

    Mike
    Participant

    Can confirm that after flashing the image I created above to the sd card, and powering on the pi, headless boot completed successfully, I was able to connect with ssh, and was able to ping externally. Unfortunately I didn’t have a lot of time because it was during lunch so I didn’t get to test anything else but at first glance it works great.

    One thing to keep in mind, make sure during the configuration that the static IP you’re assigning to your network interface is on the same network as the DHCP server you’re plugging into. I have a private testing network at home that is 192.168.50.0/24 (as opposed to the 192.168.1.0/24 network in the walkthrough) so plan accordingly and make sure no other devices on the network have the IP you’re assigning to this Kali instance.

  • #17087

    Mike
    Participant

    I should also mention that in the interest of time, I skipped the chroot step in exercise 5 and added those tools using the same extras section I used to add gnupg.

    My pi is currently setup as a media server and I wasn’t sure when I’d have time to do the chroot exercise. I was already familiar with it though so I skipped it.

  • #17088

    Mike
    Participant

    If you’re not familiar with the chroot process though, I do recommend following the steps.

  • #17091

    James Hadley
    Participant

    Hi Mike,

    Yes; as you have too, I now have a happily booting RPI that (in principle) answers the question as set. I do, however, have a distinct issue that I probably should have foreseen…..

    I’m on WIFI only so have zero connectivity. 🙂 Having a headless RPI that autoconnects to WIFI on reboot seems a worthwhile objective so the chroot process gives me an ideal opportunity to sort the problems out.

    Regards, James

You must be logged in to reply to this topic.

Back to Top