Mistake in the Book Excercise 2-3 – 'e' doesn't work on Live

This topic contains 1 reply, has 2 voices, and was last updated by  Karen Jude 2 months, 3 weeks ago.

  • Author
    Posts
  • #17354

    Max
    Participant

    Hi Kali Linux Team,

    I’ve found a mistake in the book. In Chapter 2 , exercise 2-3 boot options – you presented an answer to press ‘e’ when boot from live USB. As I checked there is no ‘e’ option when you boot Kali Linux from Live USB as there is no GRUB boot loader (as on permanently installed Kali Linux). There is a TAB option which allows you to edit the menu items.

    Could you tell me how you were able to have this ‘e’ option in the Live USB as there is no such option in Kali Linux ISO downloaded from your site ?

  • #17389

    Karen Jude
    Participant

    Hi all, I had the same experience as Max when following this exercise on a virtualbox vm but not on a physical box, where the e and c options were present on the main screen of the installer. My physical box is a UEFI machine so I tried enabling the ‘EFI (special OSes Only)’ option in the virtualbox vm settings (under system/motherboard). This solved the problem so I now have functional e and c options and can follow the exercise in the virtualbox vm too.

    Possibly this lack of functionality is caused by older bios firmware rather than lack of GRUB bootloader on live install (which I do not believe is the case anyway…).

    Further technical clarification on this one from the Kali team would be great 🙂

You must be logged in to reply to this topic.

Back to Top